Hello... new puma owner here!

New to ProjectPuma? Just got your first Puma? Looking to buy? This is the place to introduce yourself!

Moderator: Moderators

Post Reply
GrassrootsPuma
Newbie
Newbie
Posts: 2
Joined: Tue Aug 11, 2020 12:15 pm
Model: 1.7

Hello... new puma owner here!

Post by GrassrootsPuma » Tue Aug 11, 2020 6:54 pm

Evening All

I purchased a 2001 1.7 Puma over the weekend, been wanting a Puma for a few years and finally have one now :grin: fairly good condition in and out but has a few issues... please help or point me in the right direction

A bit of history of the car, reg Y409 MDF, anyone know the car?
Has had The following done in the past 2 years.
- timing belt and water pump replaced
- new exhaust
- new spark plugs, ht leads and coil pack
From the Gloucester/Worcester region

1) Hot air blowing out of heater, I’ve read HCV is the issue so plan to sort that... How do you check the heater panel?
2) radio has no power! Checked the 22 fuse, all ok.
3) concerned the Engine fan Isn’t working, car temp stays vertical but would expect the fan to come on in this heat.
4) judders slightly when releasing the throttle

Any help would be appreciated, I’m fairly good with cars, owned MX5’s for the past 10 years, the fords just a bit different so keen to learn

Thanks

Ollie
0 x

User avatar
russv
Project Regular
Project Regular
Posts: 203
Joined: Sat Oct 29, 2011 6:35 pm
Model: Other
Location: Chelmsford, Essex

Hello... new puma owner here!

Post by russv » Thu Aug 13, 2020 5:39 pm

Hi, congrats on your new purchase, hope you have lots of fun times ahead :)

Have you checked the MOT history? Looks like its had a bit of welding to pass the last MOT: https://www.check-mot.service.gov.uk/

1) Its way more likely to be the HCV, I got a blueprint one when mine stopped working, it seems to be fine so far. Sometimes you can hear a bad HCV, it makes a kind of repeating thud or dull clicking sound as its trying to open the valve but can't. The really cheap HCVs apparently don't last long at all, but I have no personal experience of them.
2) Check the wires, might be that the previous owner had an aftermarket stereo, and fitted the original back when they put the car up for sale, and might not have plugged it in properly. You can get a stereo removal tool off ebay, just a couple of quid.
3) Mine usually takes a little while to come on even in the heat, say 5-10 mins of being stationary or in a jam. All I can suggest it leave it for 10 mins, and if it hasn't come on, then check the electrics, make sure its getting power.
4) Not sure, I think it can be a few different things, maybe dirty MAF sensor, intake leak. Its best to have a mechanic look at it really, they can do some tests. If you're in the Essex area you can try the local puma specialists, pumashacked or performance puma. Maybe someone else will chime in.

Can also plug in an obd reader and see if you have any fault codes, but if you're going to a mechanic anyway I'd let them do it.

Hope that helps :)
1 x

User avatar
red
Site Administrator
Site Administrator
Posts: 11323
Joined: Wed Oct 03, 2007 4:31 pm
Model: Other
Location: Cambridgeshire
Contact:

Hello... new puma owner here!

Post by red » Fri Aug 14, 2020 9:22 am

Hello and welcome
0 x
FRP#0201 (2000) 2009-2011
Melina Blue (1999) 2006-2009
Moondust Silver (2000) 2006

GrassrootsPuma
Newbie
Newbie
Posts: 2
Joined: Tue Aug 11, 2020 12:15 pm
Model: 1.7

Hello... new puma owner here!

Post by GrassrootsPuma » Sat Aug 15, 2020 9:31 am

Morning chaps

Thanks for your replies... I can only see one bit of welding on the sill, have a chance to put it on a ramp today so going to have a look underneath and hopefully see if I can find the leak and check the condition 🧐

Got radio keys now so will sort the radio out, plan to order HCV this weekend also. The fan works with aircon but haven’t seen it come on in normal driving yet but the temp doesn’t rise.

No codes on OBD

Thanks for your help 👍🏻
0 x

Pumanick
Adolescent
Adolescent
Posts: 24
Joined: Tue Dec 17, 2019 11:07 am
Model: 1.7

Hello... new puma owner here!

Post by Pumanick » Sun Aug 16, 2020 8:17 am

Hi and welcome from a fellow Puma and MX5 owner.
0 x

Post Reply

Return to “Newbie Area”