Engine feels clogged and slow + high idle

ProjectPuma

Help Support ProjectPuma:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

Glitched Synth

New member
Joined
Dec 24, 2023
Messages
8
Location
Essex
Hey guys, I have been having issues with my car as of recently. 3 weeks ago my fuel pump failed and I had it replaced ever since but I feel like something is going on where the engine is still not happy. I remember the on couple of drives the engine would need a lot more throttle than normal but the revs don't climb up as quickly. There were moments I nearly stalled multiple times. When I floor it it climbs up pretty slowly, in first gear sometimes it struggles to pull away and sometimes it would give like a really weird pop. I'm sure it must have been from the exhaust but I'm not sure if that's got to do with the fuel injectors or the fuel filter being clogged up a little bit because of the fuel pump failing and maybe the gunk is holding back the performance a bit. I'm also not sure if it's anything to do with TPS, I hear sometimes it's a bit of an issue. To be fair the car still high idles around 1.5k and when it starts up it goes up to 2k and stays there a bit. Anyone have any suggestions? I'm not sure if I'm on the right track or if I'm missing something.
 
Hey guys, I have been having issues with my car as of recently. 3 weeks ago my fuel pump failed and I had it replaced ever since but I feel like something is going on where the engine is still not happy. I remember the on couple of drives the engine would need a lot more throttle than normal but the revs don't climb up as quickly. There were moments I nearly stalled multiple times. When I floor it it climbs up pretty slowly, in first gear sometimes it struggles to pull away and sometimes it would give like a really weird pop. I'm sure it must have been from the exhaust but I'm not sure if that's got to do with the fuel injectors or the fuel filter being clogged up a little bit because of the fuel pump failing and maybe the gunk is holding back the performance a bit. I'm also not sure if it's anything to do with TPS, I hear sometimes it's a bit of an issue. To be fair the car still high idles around 1.5k and when it starts up it goes up to 2k and stays there a bit. Anyone have any suggestions? I'm not sure if I'm on the right track or if I'm missing something.
When was the fuel filter changed ? dropping the tank may have caused sediment to have blocked me filter.
 
There are a long list of things it could be. High idle suggests idle control valve - replace! Maf sensor - clean. Good luck.
 
There are a long list of things it could be. High idle suggests idle control valve - replace! Maf sensor - clean. Good luck.
I remember one time when when me and my friend tested the engine, we decided to unplug the ICV and for some reason the car went back to behaving normally. Like the idle was steady. I don't know why, I don't know where there could be a vacuum leak.
 
It was changed roughly 5 months ago when I was doing the timing belt for it. Is there a way to clean the fuel filter?
As far as I'm aware there's no way to clean the filter, replacements are not that expensive.
Have read the original post again and it still sounds like lack of fuel, I may well be wrong, but I always think simple things first.
 

Latest posts

Back
Top