ABS and TC lights are on

URGENT ASSISTANCE REQUIRED!

Moderator: Moderators

Post Reply
Hennie_Pilsboas
Newbie
Newbie
Posts: 3
Joined: Thu Feb 28, 2019 12:24 pm
Model: 1.7
Location: The Netherlands, Delden (OV)

ABS and TC lights are on

Post by Hennie_Pilsboas » Thu Jun 06, 2019 8:50 am

Hello everyone!
Firstly I am quite new here and I recently bought a Ford Puma 1.7 1997. I really like the car and already have fitted a new radio and a new Exhaust can be delivered everyday from now on!

However I have 1 problem. When I start the car the lights will come up, and will go of. Sometimes they will stay off for a while and sometimes they pop up and will remain on for around 15 Km ( 10 Miles). Now this morning the lights were off, but then i drove around 15 km/h (10 mph) and I heard a weird sound, like pumping sounds, this happened 2 or 3 times in 10 seconds and then the ABS and TC lights came up again. I think I hear the ABS Pump pumping, but I am not an expert (yet) in that area.

Does someone know if this is the ABS Pump or the Sensors, or does someone have the same problem?
Help is appreciated!! :wink:

Btw, as you may have read, I am from the Netherlands so my English is not on point! :lol:
0 x

User avatar
red
Site Administrator
Site Administrator
Posts: 11120
Joined: Wed Oct 03, 2007 4:31 pm
Model: Other
Location: Cambridgeshire
Contact:

ABS and TC lights are on

Post by red » Thu Jun 06, 2019 1:41 pm

Welcome to the site, there is an ABS self test at around that speed (10-15) and if there's a fault detected the light will stay on.
The first place to start (in my opinion) is to test each of the 4 sensors and ensure they are free from debris toward the tone wheels.
0 x
FRP#0201 (2000) 2009-2011
Melina Blue (1999) 2006-2009
Moondust Silver (2000) 2006

Hennie_Pilsboas
Newbie
Newbie
Posts: 3
Joined: Thu Feb 28, 2019 12:24 pm
Model: 1.7
Location: The Netherlands, Delden (OV)

ABS and TC lights are on

Post by Hennie_Pilsboas » Thu Jun 06, 2019 1:58 pm

Thank you!

Then I will check the 4 sensors first, I have read that it is a common problem and the front sensors are mostly the troublemakers. however, my ABS/TC lights are not permanently on, sometimes for a long time, sometimes for a short time. Very weird.

But thank you! I will try to check them as soon as possible!
0 x

User avatar
Wild E. Coyote
Guru!
Guru!
Posts: 2440
Joined: Wed Apr 13, 2011 9:47 am
Model: 1.7
Location: Croatia

ABS and TC lights are on

Post by Wild E. Coyote » Thu Jun 06, 2019 6:38 pm

Use multimeter and check resistance. You should get something close to 1100 Ohm. Since the problem is intermittent, I would check the connectors, perhaps some corrosion has settled in...?
0 x

Post Reply

Return to “HELP ME!”